当前位置:首页 > 股票公式 » 真MACD日周指标公式

真MACD日周指标公式

真MACD日周指标公式

  {周macd柱线}

  MACD周:=MACD.MACD#WEEK,NODRAW;

  {爱迪股票公式}

  STICKLINE(MACD周>=0,0,MACD周,4.2,0),COLOR0080FF;

  STICKLINE(MACD周>=0 AND MACD周STICKLINE(MACD周<0,0,MACD周,4.2,0),COLORLIBLUE;

  STICKLINE(MACD周<0 AND MACD周>REF(MACD周,WEEKDAY),0,MACD周,4.2,0),COLOR0080FF;

  {日MACD的柱线}

  MACD2:=2*("MACD.DIF" - "MACD.DEA");

  STICKLINE(MACD2>=0,0,MACD2,1.4,0),COLOR000096;

  STICKLINE(MACD2>=0,0,MACD2,1.2,0),COLOR0000A5;

  STICKLINE(MACD2>=0,0,MACD2,1.0,0),COLOR0000B4;

  STICKLINE(MACD2>=0,0,MACD2,0.8,0),COLOR0000C3;

  STICKLINE(MACD2>=0,0,MACD2,0.6,0),COLOR0000D2;

  STICKLINE(MACD2>=0,0,MACD2,0.4,0),COLOR0000E1;

  STICKLINE(MACD2>=0,0,MACD2,0.2,0),COLOR0000F0;

  STICKLINE(MACD2>=0,0,MACD2,0.05,0),COLOR0000FF;

  STICKLINE(MACD2>=0 AND MACD2STICKLINE(MACD2>=0 AND MACD2STICKLINE(MACD2>=0 AND MACD2STICKLINE(MACD2>=0 AND MACD2STICKLINE(MACD2>=0 AND MACD2STICKLINE(MACD2>=0 AND MACD2STICKLINE(MACD2>=0 AND MACD2STICKLINE(MACD2>=0 AND MACD2STICKLINE(MACD2<0,0,MACD2,1.4,0),COLOR009600;

  STICKLINE(MACD2<0,0,MACD2,1.2,0),COLOR00A500;

  STICKLINE(MACD2<0,0,MACD2,1.0,0),COLOR00B400;

  STICKLINE(MACD2<0,0,MACD2,0.8,0),COLOR00C300;

  STICKLINE(MACD2<0,0,MACD2,0.6,0),COLOR00D200;

  STICKLINE(MACD2<0,0,MACD2,0.4,0),COLOR00E100;

  STICKLINE(MACD2<0,0,MACD2,0.2,0),COLOR00F000;

  STICKLINE(MACD2<0,0,MACD2,0.05,0),COLOR00FF00;

  STICKLINE(MACD2<0 AND MACD2>REF(MACD2,1),0,MACD2,1.4,0),COLOR000096;

  STICKLINE(MACD2<0 AND MACD2>REF(MACD2,1),0,MACD2,1.2,0),COLOR0000A5;

  STICKLINE(MACD2<0 AND MACD2>REF(MACD2,1),0,MACD2,1.0,0),COLOR0000B4;

  STICKLINE(MACD2<0 AND MACD2>REF(MACD2,1),0,MACD2,0.8,0),COLOR0000C3;

  STICKLINE(MACD2<0 AND MACD2>REF(MACD2,1),0,MACD2,0.6,0),COLOR0000D2;

  STICKLINE(MACD2<0 AND MACD2>REF(MACD2,1),0,MACD2,0.4,0),COLOR0000E1;

  STICKLINE(MACD2<0 AND MACD2>REF(MACD2,1),0,MACD2,0.2,0),COLOR0000F0;

  STICKLINE(MACD2<0 AND MACD2>REF(MACD2,1),0,MACD2,0.05,0),COLOR0000FF;

  {周DIF,周DEA}

  周DIF:MACD.DIF#WEEK,COLORGRAY,NODRAW;

  周DEA:MACD.DEA#WEEK,COLORGRAY,NODRAW;

  周macd金叉:=周DIF>周DEA;

  周均线多头排列:=周DIF<周DEA;

  STICKLINE(周macd金叉,周DIF,周DEA,0,0),COLOR008080;

  STICKLINE(周均线多头排列,周DIF,周DEA,0,0),COLORBLUE;

  {MACD月线的背驰}

  ZA1:=BARSLAST(REF(CROSS(周DIF,周DEA),1));

  周底背离:=REF(CLOSE,ZA1+1)>CLOSE AND 周DIF>REF(周DIF,ZA1+1) AND CROSS(周DIF,周DEA);

  ZA2:=BARSLAST(REF(CROSS(周DEA,周DIF),1));

  周顶背离:=REF(CLOSE,ZA2+1)周DIF AND CROSS(周DEA,周DIF);

  DRAWTEXT(周底背离,周DIF*1.02,'周底背'),COLORWHITE;

  DRAWTEXT(周顶背离,周DIF*1.02,'周顶背'),COLORGREEN;

  {日均线DIF和DEA}

  DIF:EMA(CLOSE,12)-EMA(CLOSE,26)COLORLIMAGENTA,LINETHICK2;

  DEA:EMA(DIF,9)COLORFF0080;

  MACD:2*(DIF-DEA)COLORWHITE,NODRAW;

  {MACD日均线底背离}

  A1:=BARSLAST(REF(CROSS(DIF,DEA),1));

  底背离:=REF(CLOSE,A1+1)>CLOSE AND DIF>REF(DIF,A1+1) AND CROSS(DIF,DEA);

  DRAWTEXT


上一篇:东财通財富滔滔
下一篇:通达信拐点支撑主图指标公式

猜你喜欢


MACD“双线合一”抄底法,股票短线操作技巧视频

MACD双线合一抄底法,股票短线操作技巧视频 以上就是关于MACD双线合一抄底法,股票短线操作技巧视频的所有内容,了解更多关于股票的公式就关注德力普股票行情网。...

发布时间:2019-11-26 查看次数:198
二维码