当前位置:首页 > 股票公式 » 金字塔式左右提升多头空头对策交易软件金字塔式公式计算

金字塔式左右提升多头空头对策交易软件金字塔式公式计算

金字塔式左右提升多头空头对策交易软件金字塔式公式计算

  金字塔模型对策源代码:runmode:0;

  input:period(70,5,90,5);

  input:initialstop(2,0,3,1),coststop(2,1,3,1),trailingstop(3,1,6,1);

  input:money(0,0,10,1);

  input:slippage(1,0,1,1);

  input:debug(0,0,1,1);

  variable:myasset=500000;

  variable:costprice=0,stopline=0;

  begin

  if stricmp(MArketlabel,'sh')=0 then begin

  commission:=0.001;

  stamptax:=0.001;

  transferfee:=0.001;

  end

  if stricmp(marketlabel,'sz')=0 then begin

  commission:=0.001;

  stamptax:=0.001;

  transferfee:=0;

  end

  topband:=ref(hhv(high,period),1)+mindiff;

  atr:=ref(ma(tr,10),1);

  initialstopnum:=trimprice(initialstop*atr);

  coststopnum:=trimprice(coststop*atr);

  trailingstopnum:=trimprice(trailingstop*atr);

  slippagenum:=slippage*mindiff;

  end

  if holding=0 then begin

  price:=0;

  lots:=0;

  if barpos>=period and high>=topband then

  price:=close+slippagenum;

  if price>0 then begin

  mycash:=cash(0);

  lots1:=intpart(mycash/(price*VOLunit))*volunit;

  if money=0 then begin

  lots:=lots1;

  end else begin

  lots2:=intpart(mycash*0.01*money/(initialstopnum*volunit))*volunit;

  lots:=min(lots1,lots2);

  end

  end

  if lots>=1 then begin

  buy(1,lots,limitr,price);

  if workmode=1 then

  tbuy(1,lots,limitr,price);

  end

  end

  if holding>0 then begin

  price:=0;

  lots:=holding;

  if initialstop>0 then begin

  if stopline>0 and low<=stopline then

  price:=close-slippagenum;

  if stopline=0 then begin

  costprice:=trimprice((enterprice*(1+commission)+2*transferfee)/(1-commission-stamptax))+mindiff;

  stopline:=costprice-initialstopnum;

  end

  if stopline=costprice then

  stopline:=costprice;

  if stopline>=costprice and high-trailingstopnum>stopline then

  stopline:=high-trailingstopnum;

  end

  if price>0 then begin

  sell(1,lots,limitr,price);

  costprice:=0;

  stopline:=0;

  myasset:=asset;

  if workmode=1 then

  tsell(1,lots,limitr,price);

  end

  end

  partline(debug=1 and holding=0,topband,colorred,1);

  if initialstop>0 then begin

  if holding>0 then begin

  drawicon(stoplinedrawicon(stopline=costprice,stopline,12);

  drawicon(stopline>costprice,stopline,10);

  end

  end

  if debug=1 then begin

  赢亏:myasset,noaxis,colormagenta;

  盈利:(myasset-500000)/500000,linethick0;

  频次:totaltrade,linethick0;

  胜点:percentwin,linethick0;

  连亏:maxseqloss,linethick0;

  连赢:maxseqwin,linethick0;

  end


上一篇:倚天现货交易短线指标源代码之基因变异KDJ图下
下一篇:晶晶资产(大智慧公式 副图 源代码 检测图)

猜你喜欢


通达信公式金牌股票短线战法

通达信公式金牌股票短线战法 MA13:MA(C,13),COLORWHITE; MA77:MA(C,77),COLORFF00FF; MA99:MA(C,99),COLORFFCC66; VV1:=MAX(MAX(MA13,MA77),MA99); VV2:=MIN(MIN(MA13,MA77),MA99); 粘合:=(VV1-VV2)/VV20.09 AND MA77=REF(MA77,1) AND MA99=RE...

发布时间:2019-11-27 查看次数:54
二维码