关闭

当前位置大力 > 股票知识 > » 正文

通达信启动进场优化主图指标公式

EMA3:=EMA(C,3),COLORWHITE,LINETHICK1;
EMA13:=EMA(C,13),COLORYELLOW;
EMA21:EMA(C,21),COLORWHITE,LINETHICK1;
EMA55:=EMA(C,55),COLORGREEN;
AR1:=EMA21>EMA13 AND EMA13>EMA3;
AR2:=BARSLAST((C-EMA3)/EMA3*100<-6);
AR3:=EMA3>=REF(EMA3,2);
AR4:=COUNT(CROSS(C,EMA3),AR2)=1;
AR5:=AR1 AND AR2 AND AR3 AND AR4;
AR6:=AR5 AND FILTER(AR5,10);
DRAWTEXT(AR6,L-0.09,'启动'),COLORYELLOW;
STICKLINE(AR6,H,L,0.5,1),COLORYELLOW;
{STICKLINE(AR6,O,C,6,1),LINETHICK2,COLORYELLOW;}
BR1:=COUNT(BETWEEN((C-REF(C,1))/REF(C,1)*100,0,5) ,5)=5;
BR2:=ABS((EMA3-EMA13)+(EMA13-EMA21))/C<0.2;
BR3:=C>EMA21 AND (REF(C,1)<REF(EMA21,1) OR REF(C,2)<REF(EMA21,2) OR REF(C,3)<REF(EMA21,3) OR REF(C,4)<REF(EMA21,4) OR REF
(C,5)<REF(EMA21,5));
BR4:=BR1 AND BR2 AND BR3;
{DRAWTEXT(BR4 AND FILTER(BR4,10),L-0.09,'蚂转强'),COLOR00C5FF;}
{STICKLINE(BR4 AND FILTER(BR4,10),H,L,0.5,1),COLOR00C5FF;}
{STICKLINE(BR4 AND FILTER(BR4,10),O,C,6,1),LINETHICK2,COLOR00C5FF;}
CR1:=(C-REF(C,1))/REF(C,1)*100>0.5;
CR2:=V>MA(V,5)*0.6;
CR3:=COUNT(CROSS(EMA3,EMA21),3)=1;
CR4:=ABS(EMA13-EMA21)/EMA21<0.03;
CR5:=EMA21<=EMA55 AND EMA21>=REF(EMA21,1);
CR6:=FILTER(CR1 AND CR2 AND CR3 AND CR4 AND CR5,2);
{STICKLINE(CR6,H,L,0.5,1),COLORF00FF0;}
{STICKLINE(CR6,O,C,6,1),LINETHICK2,COLORF00FF0;}
{DRAWTEXT(CR6,L-0.09,'侠拉升2'),COLORF00FF0;}
DR1:=EMA3>EMA13 AND EMA13<EMA21;
DR2:=BARSLAST(CROSS(C,EMA21) );
DR3:=H=HHV(H,DR2);
DR4:=BARSLAST(DR3);
DR5:=COUNT(O>C AND C<REF(C,1) AND C>EMA21 AND BETWEEN((C-EMA21)/EMA21,0,0.02),DR4)=1;
DR6:=C>REF(C,1) ;
DR7:= DR1 AND DR5 AND DR6 ;
DR8:=DR7 AND FILTER(DR7 ,10);
{DRAWTEXT(DR8,L-0.09,'黑拉升1'),COLORD6BA63;}
{STICKLINE(DR8,H,L,0.5,1),COLORD6BA63;}
{STICKLINE(DR8,O,C,6,1),LINETHICK2,COLORD6BA63;
ER:=BARSLAST(REF(CROSS(EMA21,EMA13),1)) AND CROSS(EMA13,EMA21);
DRAWTEXT(ER,L-0.09,'均上攻'),COLOR0099FF;}
{STICKLINE(ER,H,L,0.5,1),COLOR0099FF;}
{STICKLINE(ER,O,C,6,1),LINETHICK2,COLOR0099FF;}
FR:=BARSLAST(REF(CROSS(EMA13,EMA3),1)) AND CROSS(EMA3,EMA13);
{DRAWTEXT(FR,L-0.09,'梅上升中继'),COLORWHITE;
STICKLINE(FR,H,L,0.5,1),COLORWHITE;}
{STICKLINE(FR,O,C,6,1),LINETHICK2,COLORWHITE;}
GR1:=BARSLAST(BETWEEN("BIAS.BIAS2"(6,3,24),0,5) );
GR2:=EMA3>EMA13 AND EMA13>EMA21 AND EMA3>REF(EMA3,1);
GR3:=COUNT("BIAS.BIAS2"(6,3,24)>10 AND H=HHV(H,GR1),GR1);
GR4:=H=HHV(H,GR1);
GR5:="MACD.MACD"(12,26,9)<REF("MACD.MACD"(12,26,9),1);
GR6:=GR2 AND GR3 AND GR4;
GR7:=GR2 AND GR3 AND GR4 AND GR5;
DRAWTEXT(GR6 AND GR7,H+0.3,'见逃顶'),COLOR00FF00;
STICKLINE(GR6 AND GR7,H,H+0.09,4,0),COLOR00FF00;
HR2:=EMA3>=REF(EMA3,3) AND EMA13>=REF(EMA13,1) AND EMA21>=REF(EMA21,1) AND CROSS(C,EMA3) AND CROSS(C,EMA13) AND CROSS
(C,EMA21){ AND CROSS(C,EMA55)};
DRAWTEXT(HR2 AND FILTER(HR2,10),L-0.09,'进场! '),COLORFFC8FF;
STICKLINE(HR2 AND FILTER(HR2,10),H,L,0.5,1),COLORFFC8FF;
{STICKLINE(HR2 AND FILTER(HR2,10),O,C,6,1),LINETHICK2,COLORFFC8FF;};
MA1:=MA(CLOSE,34),COLORBLUE;
K1:=(C+H+L)/3;
D1:=MA(K1,4);
高:=REF(HHV(H,80),1);
低:=REF(LLV(L,80),1);
顶点:REFDATE(高,DATE),COLORGREEN,LINETHICK1;
低点:REFDATE(低,DATE),COLORRED,LINETHICK1;
AA05:=MA(C,5),LINETHICK2,COLOR00CCFF;
BB05:=ATAN((AA05/REF(AA05,1)-1)*100)*180/3.1416;
IF(BB05>30 AND AA05>REF(AA05,1), AA05,DRAWNULL),LINETHICK2,COLORRED;
{DRAWTEXT(REF(C,1)>D1 AND C<D1 AND D1>REF(D1,1),H*1.02,'卖'),COLORGREEN;
DRAWTEXT(REF(C,1)<D1 AND C>D1 AND D1<REF(D1,1),L*0.98,'买'),COLORRED;};
Z1:=STRCAT(HYBLOCK,' ');
Z2:=STRCAT(Z1,DYBLOCK);
Z3:=STRCAT(Z2,' ');
DRAWTEXT_FIX(ISLASTBAR,0.4,0.04,0,EXTERNSTR(0,3)),COLORWHITE;
DRAWTEXT_FIX(ISLASTBAR,0.4,0.07,0,EXTERNSTR(0,6)),COLORLIBLUE;
DRAWTEXT_FIX(ISLASTBAR,0.4,0.1,0,EXTERNSTR(0,12)),COLORLIGREEN;
DRAWTEXT_FIX(ISLASTBAR,0.35,0.08,0,FGBLOCK),COLORLIMAGENTA;
DRAWTEXT_FIX(ISLASTBAR,0.4,0.13,0,EXTERNSTR(0,1)),COLORYELLOW;
总额:=AMOUNT;
买:=IF(O=C AND (C-REF(C,1))/REF(C,1)*100>9.8,AMOUNT,AMOUNT/((H-L)*2-ABS(O-C))*(C-L));
买%:=买/AMOUNT*100;
流入:=AMOUNT*买%/10000000000;
流出:=AMOUNT/100000000-流入;
净流:=流入-流出;
净流3:=SUM(流入-流出,3);
净流5:=SUM(流入-流出,5);
净流10:=SUM(流入-流出,10);
总额10:=SUM(AMOUNT,10);
画:=CONST(FINDHIGH(总额10,0,190,1));{股旁网 }
DRAWTEXT_FIX(CURRBARSCOUNT=30,0.08,0.08,0,'净流亿(135):'),COLOR0099FF;
DRAWNUMBER_FIX(CURRBARSCOUNT=25,0.17,0.08,0,CONST(净流)),COLORRED;
DRAWNUMBER_FIX(CURRBARSCOUNT=19,0.22,0.08,0,CONST(净流3)),COLORYELLOW;
DRAWNUMBER_FIX(CURRBARSCOUNT=13,0.26,0.08,0,CONST(净流5)), COLORFF00FF;
量比:V/REF(V,1)COLORYELLOW NODRAW;
所属地域:DRAWTEXT_FIX(1,0.005,0.05,0,DYBLOCK),COLORWHITE;
所属行业:DRAWTEXT_FIX(1,0.005,0.1,0,HYBLOCK),COLORWHITE;
所属概念:DRAWTEXT_FIX(1,0.005,0.15,0,GNBLOCK),COLORWHITE;
SSTS:=STRCAT(STRCAT('上市:',CON2STR(FINANCE(42)/1,0)),'天');
LTSZ:=STRCAT(STRCAT('流通市值:',CON2STR(FINANCE(40)/100000000,0)),'亿');
YSTB:=STRCAT(STRCAT('营收同比:',CON2STR(FINANCE(44)/1,2)),'%');
LRTB:=STRCAT(STRCAT('利润同比:',CON2STR(FINANCE(43)/1,2)),'%');
DRAWTEXT_FIX(1,0.005,0,0,SSTS),COLORWHITE;
DRAWTEXT_FIX(1,0.085,0,0,LTSZ),COLORWHITE;
DRAWTEXT_FIX(1,0.185,0,0,YSTB),COLORWHITE;
DRAWTEXT_FIX(1,0.285,0,0,LRTB),COLORWHITE;
净资收益率:=(FINANCE(33)/FINANCE(34)*100);
主营利润率:=(FINANCE(23)/FINANCE(20)*100);
主营业增长率:=FINANCE(44);
每股净资产:=CONST(FINANCE(34));
每股收益:=CONST(FINANCE(38));
净利润增长率:=FINANCE(43);
市销率:=CONST(FINANCE(1)*DYNAINFO(7)/FINANCE(20));
现金负债比:=(FINANCE(25)/FINANCE(15));
每股未分配:=CONST(FINANCE(32));
每股公积金:=CONST(FINANCE(18));
SY01:=净资收益率>3;
SY02:=净资收益率>0.01 AND 净资收益率<=3;
SY03:=主营利润率>2;
SY04:=主营利润率>0;
SY05:=主营业增长率>1;
SY06:=主营业增长率>0;
SY07:=净利润增长率>2;
SY08:=净利润增长率>0.2;
SY09:=每股收益>0.01;
SY10:= 每股收益>0.001;
SY11:=每股净资产>2;
SY12:=每股净资产>0.01;
SY13:=每股未分配>0.5;
SY14:=每股未分配>0.001;
SY15:=每股公积金>0.5;
SY16:=每股公积金>0.002;
SY17:=每股未分配>=2 AND 每股公积金>=2;
SY18:=每股未分配<2 OR 每股公积金<2;
优秀:=SY01 AND SY03 AND SY05 AND SY07 AND SY09 AND SY11
AND SY13 AND SY15;
较好:=SY02 AND SY04 AND SY06 AND SY08 AND SY10 AND SY12
AND SY14 AND SY16;
一般:=NOT(优秀) AND NOT(较好);
DRAWTEXT_FIX(优秀 AND 较好=0,0.45,0,0,'综合评估基本面:优秀!'),COLORMAGENTA;
DRAWTEXT_FIX(较好,0.45,0,0,'综合评估基本面:较好!'),COLORRED;
DRAWTEXT_FIX(一般,0.45,0,0,'综合评估基本面:一般!'),COLORGREEN;
DRAWTEXT_FIX(SY17,0.65,0,0,'是否具备高送转潜力:是!'),COLORMAGENTA;
DRAWTEXT_FIX(SY18,0.65,0,0,'是否具备高送转潜力:否!'),COLORGREEN;
AA1:=SUM(IF(CLOSE>REF(CLOSE,1),VOL/CAPITAL*100,IF(CLOSE<REF(CLOSE,1),-
VOL/CAPITAL*100,0)),0);
成交额:=V*C/100,NODRAW;{万元}
AA2:=SUM((IF(((成交额/8>20) AND (CLOSE>(REF(CLOSE,1)))),成交额,0)),0);
AA3:=SUM((IF(((成交额/8>20) AND (CLOSE<(REF(CLOSE,1)))),成交额,0)),0);
AA4:=SUM((IF(((成交额/8<20) AND (CLOSE>(REF(CLOSE,1)))),成交额,0)),0);
AA5:=SUM((IF(((成交额/8<20) AND (CLOSE<(REF(CLOSE,1)))),成交额,0)),0);
AA6:=((AA2+AA3)+AA4)+AA5;
DD1:=1;
AAA1:=STRCAT(STRCAT('机构持有',CON2STR((100*AA2)/AA6,0)),'%');
AAA2:=STRCAT(STRCAT('散户持有',CON2STR((100*AA3)/AA6,0)),'%');
DRAWTEXT_FIX(DD1=1,0.9,0.9,0,AAA1),COLORRED;
DRAWTEXT_FIX(DD1=1,0.9,0.99,0,AAA2),COLORGREEN;

通达信启动进场优化主图指标公式

上一篇:通达信年线上升主图指标公式
下一篇:通达信经典波段操作主图指标公式

猜你喜欢


二维码