关闭

当前位置大力 > 股票股吧 > » 正文

莱茵生物股票:通达信MACD顶部底部结构预警副图指标源码

通达信MACD顶部底部结构预警副图指标源码(无源码的请下载附件导入),本公式由江城股票网小编收集整理发布,欢迎大家下载使用!

自从发现了这个网站后,在这里找到很多实用的指标,特别注意收集了许多MACD指标,每个指标都有自己的特点,所以总是想把各种功能组合在一起,这样就直观一些,特别适合一些像我这样的新手一样使用,在许昌舍得老师的不断帮助下,终于达到了自己想要的效果,向老师学习助人为乐的精神,所以发出来,有未来,但是通过使用不影响正常使用,不喜欢的不要喷,指标就是指标,不是交易依据。

DIF:EMA(CLOSE,12)-EMA(CLOSE,26);

 DEA:EMA(DIF,9);

 MACD:2*(DIF-DEA), COLORSTICK,LINETHICK2;

 A1:=BARSLAST(REF(CROSS(DIF,DEA),1));

底背离:=REF(CLOSE,A1+1)>CLOSE AND DIF>REF(DIF,A1+1) AND CROSS(DIF,DEA);

 STICKLINE(底背离,0,0.03,6,0),COLOR00FF00;

底背:DRAWLINE(A1=0,DEA,底背离,DEA,0),COLORRED,LINETHICK4;

 DRAWTEXT(底背离,0.12,' 底背离'),COLORFF00FF;

 A2:=BARSLAST(REF(CROSS(DEA,DIF),1));

顶背离:=REF(CLOSE,A2+1)<CLOSE AND REF(DIF,A2+1)>DIF AND CROSS(DEA,DIF);

顶背:DRAWLINE(A2=0,DEA,顶背离,DEA,0),COLORGREEN,LINETHICK4; 

 DRAWICON(CROSS(DIF,DEA),DEA,1);

 DRAWICON(CROSS(DEA,DIF),DEA,2);

 STICKLINE(MACD>REF(MACD,1)AND MACD>0,0,MACD,0.2,0),COLORRED;

 STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,0.2,0),COLORRED;

 STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,0.2,0),COLORBLUE;

 STICKLINE(MACD<REF(MACD,1)AND MACD<0,0,MACD,0.2,0),COLORBLUE;


 


 {底部结构预警}

死叉:=CROSS(DEA,DIF);

 N1:=BARSLAST(死叉),NODRAW;{最近一次死叉的位置}

N2:=REF(BARSLAST(死叉),N1+1),NODRAW;{倒数第二次死叉与倒数第一次死叉的区间}

N3:=REF(BARSLAST(死叉),N2+N1+2),NODRAW;{倒数第三次死叉与倒数第二次死叉的区间}

CL1:=LLV(C,N1+1),NODRAW;{最近一次死叉后,最低收盘价}

DIFL1:=LLV(DIF,N1+1),NODRAW;

 CL2:=REF(CL1,N1+1),NODRAW;{倒数第二次死叉与倒数第一次死叉之间的最低收盘价}

DIFL2:=REF(DIFL1,N1+1),NODRAW;

 CL3:=REF(CL2,N1+1),NODRAW;{倒数第三次死叉与倒数第二次死叉之间的最低收盘价}

DIFL3:=REF(DIFL2,N1+1),NODRAW;

 PDIFL2:=IF(DIFL2>0,INTPART(LOG(DIFL2))-1,INTPART(LOG(-DIFL2))-1);

 MDIFL2:=INTPART(DIFL2/POW(10,PDIFL2));

 PDIFL3:=IF(DIFL3>0,INTPART(LOG(DIFL3))-1,INTPART(LOG(-DIFL3))-1);

 MDIFL3:=INTPART(DIFL3/POW(10,PDIFL3));

 MDIFB2:=INTPART(DIF/POW(10,PDIFL2));

 MDIFB3:=INTPART(DIF/POW(10,PDIFL3));

直接底背离:=(CL1<CL2 ) AND (MDIFB2>MDIFL2) AND (MACD<0 AND REF(MACD,1)<0) AND MDIFB2<=REF(MDIFB2,1);

隔峰底背离:=(CL1<CL3 AND CL3<CL2 ) AND (MDIFB3>MDIFL3) AND (MACD<0 AND REF(MACD,1)<0) AND MDIFB3<=REF(MDIFB3,1);

 B:直接底背离 OR 隔峰底背离,NODRAW;

 BG:((MDIFB2>REF(MDIFB2,1))*REF(直接底背离,1)) OR ((MDIFB3>REF(MDIFB3,1))*REF(隔峰底背离,1)),NODRAW;

底背离消失:=(REF(直接底背离,1) AND DIFL1<=DIFL2 ) OR (REF(隔峰底背离,1) AND DIFL1<=DIFL3);


 


 DRAWTEXT(TFILTER(B,MACD>0,1),(DIF+MACD),'钝化'),COLORRED;

 STICKLINE(B OR BG,DIF,DEA,1,0),COLORRED;

 DRAWTEXT(TFILTER(底背离消失,B,1),(DIF+MACD),'消失'),COLORYELLOW;

 DRAWTEXT(TFILTER(BG,MACD>0,1),DIF*1.1,'结构形成'),COLORGREEN;

 {顶部结构预警}

金叉:=CROSS(DIF,DEA);

 M1:=BARSLAST(金叉),NODRAW;{最近一次金叉的位置}

M2:=REF(BARSLAST(金叉),M1+1),NODRAW;{倒数第二次金叉与倒数第一次金叉的区间}

M3:=REF(BARSLAST(金叉),M2+M1+2),NODRAW;{倒数第三次金叉与倒数第二次金叉的区间}

CH1:=HHV(C,M1+1),NODRAW;{最近一次金叉后,最高收盘价}

DIFH1:=HHV(DIF,M1+1),NODRAW;

 CH2:=REF(CH1,M1+1),NODRAW;{倒数第二次金叉与倒数第一次金叉之间的最高收盘价}

DIFH2:=REF(DIFH1,M1+1),NODRAW;

 CH3:=REF(CH2,M1+1),NODRAW;{倒数第三次金叉与倒数第二次金叉之间的最高收盘价}

DIFH3:=REF(DIFH2,M1+1),NODRAW;

 PDIFH2:=IF(DIFH2>0,INTPART(LOG(DIFH2))-1,INTPART(LOG(-DIFH2))-1);

 MDIFH2:=INTPART(DIFH2/POW(10,PDIFH2));

 PDIFH3:=IF(DIFH3>0,INTPART(LOG(DIFH3))-1,INTPART(LOG(-DIFH3))-1);

 MDIFH3:=INTPART(DIFH3/POW(10,PDIFH3));

 MDIFT2:=INTPART(DIF/POW(10,PDIFH2));

 MDIFT3:=INTPART(DIF/POW(10,PDIFH3));

直接顶背离:=(CH1>CH2 ) AND (MDIFT2<MDIFH2) AND (MACD>0 AND REF(MACD,1)>0) AND MDIFT2>=REF(MDIFT2,1);

隔峰顶背离:=(CH1>CH3 AND CH3>CH2 ) AND (MDIFT3<MDIFH3) AND (MACD>0 AND REF(MACD,1)>0) AND MDIFT3>=REF(MDIFT3,1);

 T:直接顶背离 OR 隔峰顶背离,NODRAW;

 TG:((MDIFT2<REF(MDIFT2,1))*REF(直接顶背离,1)) OR ((MDIFT3<REF(MDIFT3,1))*REF(隔峰顶背离,1)),NODRAW;

顶背离消失:=(REF(直接顶背离,1) AND DIFH1>=DIFH2 ) OR (REF(隔峰顶背离,1) AND DIFH1>=DIFH3);


 


 DRAWTEXT(TFILTER(T,MACD<0,1),(DIF+MACD),'钝化'),COLORGREEN;

 DRAWTEXT(TFILTER(顶背离消失,T,1),(DIF+MACD),'消失'),COLORYELLOW;

 STICKLINE(T OR TG,DIF,DEA,1,0),COLORGREEN;

 DRAWTEXT(TFILTER(TG,MACD<0,1),DIF*1.02,'结构形成'),COLORMAGENTA;

通达信MACD顶部底部结构预警副图指标源码

江城股票网提供股票公式和股票软件,感谢您的支持!觉得好请大家帮忙多宣传!

上一篇:大冷股份股票:通达信主力轨迹副图指标公式大智慧通用贴图
下一篇:600753股票:通达信筹码初探选股/副图指标公式贴图

猜你喜欢


高转送股

高转送股

投资者在提前挖掘出有高送转潜力的个股后,应在股价回调到位后逢低买入。 高送转股通常是由于上市公司业绩良好...

时间:2020-05-14 次数:147

稳健投资者的选股策略

假如你是一个稳健型投资者,以安全为第一考虑因素,惟恐失败,就不要买进股价易于波动并大起大落的股票。由于...

时间:2020-05-13 次数:158

300114千股千评-最新股票资金流向-中航电测股吧

这里我们介绍的是关于中航电测300114股票的个股资金流向分析,300114股吧地址的分享,以及300114近期的1些综合建议。 300114资金流向综合评价(2019.10.29) 股票代码: 300114 股票名称: 中航电...

时间:2020-01-03 次数:92
 日本蜡烛图技术6.4:捉腰

日本蜡烛图技术6.4:捉腰带线

日本蜡烛图技术6.4:捉腰带线捉腰带形态是由单独一根蜡烛线构成的,既可能具有看涨的意义,也可能具有看鉄的意...

时间:2020-03-29 次数:194
二维码